Vulnerability · Published Jul 14, 2022 · Assigned by GitHub_M

CVE-2022-31147jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306

High 7.5

In plain English

A high-severity regular-expression denial of service in jquery-validation from jquery-validation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.2% (higher than 83% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)2.2%top 17.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmjquery-validation1.19.5GHSA-ffmh-x56j-9rc3

Affected products (as reported)

VendorProductVersions
jquery-validation jquery-validation < 1.19.5

Weakness: CWE-1333 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References