Vulnerability · Published Jun 27, 2022 · Assigned by GitHub_M

CVE-2022-31091Change in port should be considered a change in origin in Guzzle

High 7.7

In plain English

A high-severity information exposure in guzzle from guzzle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)1.6%top 24.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Guzzle, an extensible PHP HTTP client. `Authorization` and `Cookie` headers on requests are sensitive information. In affected versions on making a request which responds with a redirect to a URI with a different port, if we choose to follow it, we should remove the `Authorization` and `Cookie` headers from the request, before containing. Previously, we would only consider a change in host or scheme. Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Note that a partial fix was implemented in Guzzle 7.4.2, where a change in host would trigger removal of the curl-added Authorization header, however this earlier fix did not cover change in scheme or change in port. An alternative approach would be to use your own redirect middleware, rather than ours, if you are unable to upgrade. If you do not require or expect redirects to be followed, one should simply disable redirects all together.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12guzzle7.4.5-1DEBIAN-CVE-2022-31091
Debian:13guzzle7.4.5-1DEBIAN-CVE-2022-31091
Debian:14guzzle7.4.5-1DEBIAN-CVE-2022-31091
Debian:12mediawiki1:1.35.7-1DEBIAN-CVE-2022-31091
Debian:13mediawiki1:1.35.7-1DEBIAN-CVE-2022-31091
Debian:14mediawiki1:1.35.7-1DEBIAN-CVE-2022-31091
Packagistguzzlehttp/guzzle6.5.8GHSA-q559-8m2m-g699
Packagistguzzlehttp/guzzle7.4.5GHSA-q559-8m2m-g699
Ubuntu:22.04:LTSicinga-php-thirdpartyno fix listedUBUNTU-CVE-2022-31091
Ubuntu:24.04:LTSicinga-php-thirdpartyno fix listedUBUNTU-CVE-2022-31091
Ubuntu:25.10icinga-php-thirdpartyno fix listedUBUNTU-CVE-2022-31091
Ubuntu:26.04:LTSicinga-php-thirdpartyno fix listedUBUNTU-CVE-2022-31091
Ubuntu:26.10icinga-php-thirdpartyno fix listedUBUNTU-CVE-2022-31091
Ubuntu:22.04:LTSicingaweb2-module-reactbundleno fix listedUBUNTU-CVE-2022-31091
Ubuntu:24.04:LTSicingaweb2-module-reactbundleno fix listedUBUNTU-CVE-2022-31091
Ubuntu:25.10icingaweb2-module-reactbundleno fix listedUBUNTU-CVE-2022-31091
Ubuntu:26.04:LTSicingaweb2-module-reactbundleno fix listedUBUNTU-CVE-2022-31091
Ubuntu:26.10icingaweb2-module-reactbundleno fix listedUBUNTU-CVE-2022-31091

Affected products (as reported)

VendorProductVersions
guzzle guzzle < 6.5.8>=7.0.0, < 7.4.5

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References