Vulnerability · Published Jun 14, 2022 · Assigned by GitHub_M
CVE-2022-31060Banner topic data is exposed on login-required Discourse sites
Medium 5.3
In plain English
A medium-severity information exposure in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities).
Official description
Discourse is an open-source discussion platform. Prior to version 2.8.4 in the `stable` branch and version `2.9.0.beta5` in the `beta` and `tests-passed` branches, banner topic data is exposed on login-required sites. This issue is patched in version 2.8.4 in the `stable` branch and version `2.9.0.beta5` in the `beta` and `tests-passed` branches of Discourse. As a workaround, one may disable banners.
Affected products (as reported)
Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/discourse/discourse/security/advisories/GHSA-5f4f-35fx-gqhq x_refsource_CONFIRM
- https://github.com/discourse/discourse/pull/17071 x_refsource_MISC
- https://github.com/discourse/discourse/commit/ae6a9079436fb9b20fd051d25fb6d8027f0ec59a x_refsource_MISC