Vulnerability · Published Jun 9, 2022 · Assigned by GitHub_M

CVE-2022-31042Failure to strip the Cookie header on change in host or HTTP downgrade in Guzzle

High 7.5

In plain English

A high-severity information exposure in guzzle from guzzle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.0% (higher than 81% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)2.0%top 19.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Guzzle is an open source PHP HTTP client. In affected versions the `Cookie` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, or on making a request to a server which responds with a redirect to a a URI to a different host, we should not forward the `Cookie` header on. Prior to this fix, only cookies that were managed by our cookie middleware would be safely removed, and any `Cookie` header manually added to the initial request would not be stripped. We now always strip it, and allow the cookie middleware to re-add any cookies that it deems should be there. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach to use your own redirect middleware, rather than ours. If you do not require or expect redirects to be followed, one should simply disable redirects all together.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12guzzle7.4.4-1DEBIAN-CVE-2022-31042
Debian:13guzzle7.4.4-1DEBIAN-CVE-2022-31042
Debian:14guzzle7.4.4-1DEBIAN-CVE-2022-31042
Debian:12mediawiki1:1.35.7-1DEBIAN-CVE-2022-31042
Debian:13mediawiki1:1.35.7-1DEBIAN-CVE-2022-31042
Debian:14mediawiki1:1.35.7-1DEBIAN-CVE-2022-31042
Packagistdrupal/core9.2.21, 9.3.16DRUPAL-CORE-2022-011
Packagistguzzlehttp/guzzle7.4.4GHSA-w248-ffj2-4v5q
Packagistguzzlehttp/guzzle6.5.7GHSA-w248-ffj2-4v5q
Packagistguzzlehttp/guzzle7.4.4GHSA-f2wf-25xc-69c9
Packagistguzzlehttp/guzzle6.5.7GHSA-f2wf-25xc-69c9
Ubuntu:24.04:LTSguzzleno fix listedUBUNTU-CVE-2022-31042
Ubuntu:25.10guzzleno fix listedUBUNTU-CVE-2022-31042
Ubuntu:26.04:LTSguzzleno fix listedUBUNTU-CVE-2022-31042
Ubuntu:26.10guzzleno fix listedUBUNTU-CVE-2022-31042

Affected products (as reported)

VendorProductVersions
guzzle guzzle < 6.5.7>=7.0.0, < 7.4.4

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References