Vulnerability · Published Oct 18, 2022 · Assigned by GitHub_M
CVE-2022-31037OroCommerce vulnerable to Cross-site Scripting via Shipping rule editing page
Medium 6.9
In plain English
A medium-severity cross-site scripting in orocommerce from oroinc. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OroCommerce is an open-source Business to Business Commerce application. Versions between 4.1.0 and 4.1.17 inclusive, 4.2.0 and 4.2.11 inclusive, and between 5.0.0 and 5.0.3 inclusive, are vulnerable to Cross-site Scripting in the UPS Surcharge field of the Shipping rule edit page. The attacker needs permission to create or edit a shipping rule. This issue has been patched in version 5.0.6. There are no known workarounds.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | oro/commerce | 5.0.6 | GHSA-4vf4-955g-vxp2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| oroinc | orocommerce | >= 4.1.0, <= 4.1.17>= 4.2.0, <= 4.2.11 >= 5.0.0, <= 5.0.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N