Vulnerability · Published Jun 6, 2022 · Assigned by GitHub_M

CVE-2022-31026Use of Uninitialized Variable in trilogy

Medium 5.9

In plain English

A medium-severity security flaw in trilogy from github. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)1.1%top 34.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Trilogy is a client library for MySQL. When authenticating, a malicious server could return a specially crafted authentication packet, causing the client to read and return up to 12 bytes of data from an uninitialized variable in stack memory. Users of the trilogy gem should upgrade to version 2.1.1 This issue can be avoided by only connecting to trusted servers.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemstrilogy2.1.1GHSA-5g4r-2qhx-vqfm

Affected products (as reported)

VendorProductVersions
github trilogy < 2.1.1

Weakness: CWE-908 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

References