Vulnerability · Published Sep 6, 2022 · Assigned by GitHub_M

CVE-2022-31020Remote code execution in Indy's NODE_UPGRADE transaction

High 8.8

In plain English

A high-severity improper authentication in indy-node from hyperledger. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 83% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)2.3%top 16.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIindy-node1.12.5rc1GHSA-r6v9-p59m-gj2p
PyPIindy-node1.12.5rc1PYSEC-2022-265

Affected products (as reported)

VendorProductVersions
hyperledger indy-node <= 1.12.4

Weakness: CWE-287, CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References