Vulnerability · Published Jun 25, 2022 · Assigned by GitHub_M
CVE-2022-31017Expression Always True vulnerability in Zulip Server
Low 2.0
In plain English
A low-severity security flaw in zulip from zulip. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities).
Official description
Zulip is an open-source team collaboration tool. Versions 2.1.0 through and including 5.2 are vulnerable to a logic error. A stream configured as private with protected history, where new subscribers should not be allowed to see messages sent before they were subscribed, when edited causes the server to incorrectly send an API event that includes the edited message to all of the stream’s current subscribers. This API event is ignored by official clients, but can be observed by using a modified client or the browser’s developer tools. This bug will be fixed in Zulip Server 5.3. There are no known workarounds.
Affected products (as reported)
Weakness: CWE-571, CWE-670 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N
References
- https://github.com/zulip/zulip/security/advisories/GHSA-m5j3-jp59-6f3q x_refsource_CONFIRM