Vulnerability · Published Oct 6, 2022 · Assigned by GitHub_M

CVE-2022-31008Predictable credential obfuscation seed value used in rabbitmq-server

Medium 5.5

In plain English

A medium-severity weak randomness in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.5Medium
Exploit odds (30 days)0.4%top 65.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a multi-protocol messaging and streaming broker. In affected versions the shovel and federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret. This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log. Patched versions correctly use a cluster-wide secret for that purpose. This issue has been addressed and Patched versions: `3.10.2`, `3.9.18`, `3.8.32` are available. Users unable to upgrade should disable the Shovel and Federation plugins.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-server3.10.8-1DEBIAN-CVE-2022-31008
Debian:13rabbitmq-server3.10.8-1DEBIAN-CVE-2022-31008
Debian:14rabbitmq-server3.10.8-1DEBIAN-CVE-2022-31008
Ubuntu:22.04:LTSbrokerno fix listedUBUNTU-CVE-2022-31008

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server < 3.8.32>= 3.9.0, < 3.9.18>= 3.10.0, < 3.10.2

Weakness: CWE-330 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

References