Vulnerability · Published Jun 6, 2022 · Assigned by GitHub_M
CVE-2022-29254Failed payment recorded has completed in silverstripe/silverstripe-omnipay
Low 3.7
In plain English
A low-severity security flaw in silverstripe-omnipay from silverstripe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
silverstripe-omnipay is a SilverStripe integration with Omnipay PHP payments library. For a subset of Omnipay gateways (those that use intermediary states like `isNotification()` or `isRedirect()`), if the payment identifier or success URL is exposed it is possible for payments to be prematurely marked as completed without payment being taken. This is mitigated by the fact that most payment gateways hide this information from users, however some issuing banks offer flawed 3DSecure implementations that may inadvertently expose this data. The following versions have been patched to fix this issue: `2.5.2`, `3.0.2`, `3.1.4`, and `3.2.1`. There are no known workarounds for this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | silverstripe/silverstripe-omnipay | 2.5.2 | GHSA-48f2-m7jg-866x |
| Packagist | silverstripe/silverstripe-omnipay | 3.0.2 | GHSA-48f2-m7jg-866x |
| Packagist | silverstripe/silverstripe-omnipay | 3.1.4 | GHSA-48f2-m7jg-866x |
| Packagist | silverstripe/silverstripe-omnipay | 3.2.1 | GHSA-48f2-m7jg-866x |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| silverstripe | silverstripe-omnipay | < 2.5.2>= 3.0.0, < 3.0.2>= 3.1.0, < 3.1.4>= 3.2.0, < 3.2.1 |
Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N