Vulnerability · Published Aug 4, 2022 · Assigned by apache
CVE-2022-28732Apache JSPWiki Cross-site scripting vulnerability on WeblogPlugin
Medium 6.1
In plain English
A medium-severity security flaw in Apache JSPWiki from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 82.8% (higher than 99.7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)6.1Medium
Exploit odds (30 days)82.8%top 0.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
A carefully crafted request on WeblogPlugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.3 or later.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.jspwiki:jspwiki-main | 2.11.3 | GHSA-hph8-29xw-qfxx |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache JSPWiki | Apache JSPWiki – through Apache JSPWiki up to 2.11.2 |
References
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-28732 x_refsource_MISC