Vulnerability · Published Nov 1, 2022 · Assigned by apple

CVE-2022-26717

High 8.8

In plain English

A high-severity use-after-free in macOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.0% (higher than 81% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)2.0%top 18.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

A use after free issue was addressed with improved memory management. This issue is fixed in tvOS 15.5, watchOS 8.6, iOS 15.5 and iPadOS 15.5, macOS Monterey 12.4, Safari 15.5, iTunes 12.12.4 for Windows. Processing maliciously crafted web content may lead to arbitrary code execution.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.36.7-1.el8ALSA-2022:7704
AlmaLinux:9webkit2gtk32.36.7-1.el9ALSA-2022:8054
AlmaLinux:8webkit2gtk3-devel2.36.7-1.el8ALSA-2022:7704
AlmaLinux:9webkit2gtk3-devel2.36.7-1.el9ALSA-2022:8054
AlmaLinux:8webkit2gtk3-jsc2.36.7-1.el8ALSA-2022:7704
AlmaLinux:9webkit2gtk3-jsc2.36.7-1.el9ALSA-2022:8054
AlmaLinux:8webkit2gtk3-jsc-devel2.36.7-1.el8ALSA-2022:7704
AlmaLinux:9webkit2gtk3-jsc-devel2.36.7-1.el9ALSA-2022:8054
Debian:12webkit2gtk2.36.3-1DEBIAN-CVE-2022-26717
Debian:13webkit2gtk2.36.3-1DEBIAN-CVE-2022-26717
Debian:14webkit2gtk2.36.3-1DEBIAN-CVE-2022-26717
Debian:12wpewebkit2.36.3-1DEBIAN-CVE-2022-26717
Debian:13wpewebkit2.36.3-1DEBIAN-CVE-2022-26717
Debian:14wpewebkit2.36.3-1DEBIAN-CVE-2022-26717
Rocky Linux:8webkit2gtk30:2.36.7-1.el8_6RLSA-2022:7704
Rocky Linux:9webkit2gtk30:2.36.7-1.el9_0RLSA-2022:8054
Rocky Linux:9webkit2gtk30:2.36.7-1.el9_1.1RLSA-2022:8054
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2022-26717
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2022-26717
Ubuntu:22.04:LTSwebkit2gtk2.36.3-0ubuntu0.22.04.1UBUNTU-CVE-2022-26717
Ubuntu:22.04:LTSwebkit2gtk2.36.3-0ubuntu0.22.04.1USN-5457-1
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2022-26717

Affected products (as reported)

VendorProductVersions
Apple macOS unspecified – before 12.4
Apple macOS unspecified – before 15.5
Apple watchOS unspecified – before 8.6
Apple watchOS unspecified – before 12.12
Apple watchOS unspecified – before 15.5
Apple watchOS unspecified – before 15.5

Weakness: CWE-416 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References