Vulnerability · Published Mar 30, 2022 · Assigned by apache
CVE-2022-25598Apache DolphinScheduler user registration is vulnerable to ReDoS attacks
High 7.5
In plain English
A high-severity regular-expression denial of service in Apache DolphinScheduler from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.0% (higher than 81% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)7.5High
Exploit odds (30 days)2.0%top 19.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
Apache DolphinScheduler user registration is vulnerable to Regular express Denial of Service (ReDoS) attacks, Apache DolphinScheduler users should upgrade to version 2.0.5 or higher.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.dolphinscheduler:dolphinscheduler | 2.0.5 | GHSA-qg5x-66hp-cw5p |
| PyPI | apache-dolphinscheduler | 2.0.5 | GHSA-qg5x-66hp-cw5p |
| PyPI | apache-dolphinscheduler | 2.0.5 | PYSEC-2022-176 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache DolphinScheduler | Apache DolphinScheduler – before 2.0.5 |
Weakness: CWE-1333
References
- https://lists.apache.org/thread/hwnw7xr969sg5nv84wz75nfr2c76fl93 x_refsource_MISC