Vulnerability · Published Apr 28, 2022 · Assigned by GitHub_M
CVE-2022-24879Malfunction of Cross-Site Request Forgery token validation
High 7.5
In plain English
A high-severity cross-site request forgery in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Shopware is an open source e-commerce software platform. Versions prior to 5.7.9 are vulnerable to malfunction of cross-site request forgery (CSRF) token validation. Under certain circumstances, the CSRF tokens were not generated anew and not validated correctly. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | shopware/shopware | 5.7.9 | GHSA-pf38-v6qj-j23h |
Affected products (as reported)
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
References
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022 x_refsource_MISC
- https://www.shopware.com/en/changelog-sw5/#5-7-9 x_refsource_MISC
- https://github.com/shopware/shopware/security/advisories/GHSA-pf38-v6qj-j23h x_refsource_CONFIRM