Vulnerability · Published Apr 28, 2022 · Assigned by GitHub_M
CVE-2022-24873Non-Stored Cross-site Scripting in Shopware storefront
Medium 5.4
In plain English
A medium-severity cross-site scripting in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.8%top 43.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Shopware is an open source e-commerce software platform. Prior to version 5.7.9, Shopware is vulnerable to non-stored cross-site scripting in the storefront. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | shopware/shopware | 5.7.9 | GHSA-4g29-fccr-p59w |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
References
- https://github.com/shopware/shopware/security/advisories/GHSA-4g29-fccr-p59w x_refsource_CONFIRM
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022 x_refsource_MISC
- https://www.shopware.com/en/changelog-sw5/#5-7-9 x_refsource_MISC