Vulnerability · Published Jul 13, 2023 · Assigned by GitHub_M

CVE-2022-24834Heap overflow issue with the Lua cjson library used by Redis

High 7.0

In plain English

A high-severity heap buffer overflow in redis from redis. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 41.4% (higher than 99% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.0High
Exploit odds (30 days)41.4%top 1.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

Redis is an in-memory database that persists on disk. A specially crafted Lua script executing in Redis can trigger a heap overflow in the cjson library, and result with heap corruption and potentially remote code execution. The problem exists in all versions of Redis with Lua scripting support, starting from 2.6, and affects only authenticated and authorized users. The problem is fixed in versions 7.0.12, 6.2.13, and 6.0.20.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8redis6.2.17-1.module_el8.10.0+3946+3de613d5ALSA-2025:0595
AlmaLinux:9redis6.2.17-1.el9_5ALSA-2025:0693
AlmaLinux:8redis-devel6.2.17-1.module_el8.10.0+3946+3de613d5ALSA-2025:0595
AlmaLinux:9redis-devel6.2.17-1.el9_5ALSA-2025:0693
AlmaLinux:8redis-doc6.2.17-1.module_el8.10.0+3946+3de613d5ALSA-2025:0595
AlmaLinux:9redis-doc6.2.17-1.el9_5ALSA-2025:0693
Alpine:v3.20redis7.0.12-r0ALPINE-CVE-2022-24834
Alpine:v3.21redis7.0.12-r0ALPINE-CVE-2022-24834
Alpine:v3.22redis7.0.12-r0ALPINE-CVE-2022-24834
Alpine:v3.23redis7.0.12-r0ALPINE-CVE-2022-24834
Alpine:v3.24redis7.0.12-r0ALPINE-CVE-2022-24834
Debian:12redis5:7.0.15-1~deb12u1DEBIAN-CVE-2022-24834
Debian:12redis5:7.0.15-1~deb12u1DSA-5610-1
Debian:13redis5:7.0.12-1DEBIAN-CVE-2022-24834
Debian:14redis5:7.0.12-1DEBIAN-CVE-2022-24834
Rocky Linux:8redis0:6.2.17-1.module+el8.10.0+1923+5b85c6a7RLSA-2025:0595
Rocky Linux:9redis0:6.2.17-1.el9_5RLSA-2025:0693
Ubuntu:24.04:LTSlua-cjsonno fix listedUBUNTU-CVE-2022-24834
Ubuntu:25.10lua-cjsonno fix listedUBUNTU-CVE-2022-24834
Ubuntu:26.04:LTSlua-cjsonno fix listedUBUNTU-CVE-2022-24834
Ubuntu:26.10lua-cjsonno fix listedUBUNTU-CVE-2022-24834
Ubuntu:25.10lua-cmsgpackno fix listedUBUNTU-CVE-2022-24834
Ubuntu:26.04:LTSlua-cmsgpackno fix listedUBUNTU-CVE-2022-24834
Ubuntu:26.10lua-cmsgpackno fix listedUBUNTU-CVE-2022-24834

Affected products (as reported)

VendorProductVersions
redis redis >= 7.0.0, < 7.0.12>= 6.2.0, < 6.2.13>= 6.0.0, < 6.0.20

Weakness: CWE-122, CWE-680 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References