Vulnerability · Published Apr 11, 2022 · Assigned by GitHub_M

CVE-2022-24833Persistent Cross-site Scripting (XSS) vulnerability in PrivateBin

High 8.2

In plain English

A high-severity cross-site scripting in PrivateBin from PrivateBin. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.2High
Exploit odds (30 days)1.4%top 28.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

PrivateBin is minimalist, open source online pastebin clone where the server has zero knowledge of pasted data. In PrivateBin < v1.4.0 a cross-site scripting (XSS) vulnerability was found. The vulnerability is present in all versions from v0.21 of the project, which was at the time still called ZeroBin. The issue is caused by the fact that SVGs can contain JavaScript. This can allow an attacker to execute code, if the user opens a paste with a specifically crafted SVG attachment, and interacts with the preview image and the instance isn't protected by an appropriate content security policy. Users are advised to either upgrade to version 1.4.0 or to ensure the content security policy of their instance is set correctly.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistprivatebin/privatebin1.4.0GHSA-cqcc-mm6x-vmvw

Affected products (as reported)

VendorProductVersions
PrivateBin PrivateBin >= v0.21, < v1.4.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N

References