Vulnerability · Published Mar 17, 2022 · Assigned by GitHub_M

CVE-2022-24759Failure to validate signature during handshake in @chainsafe/libp2p-noise

High 8.1

In plain English

A high-severity security flaw in js-libp2p-noise from ChainSafe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.5%top 57.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

`@chainsafe/libp2p-noise` contains TypeScript implementation of noise protocol, an encryption protocol used in libp2p. `@chainsafe/libp2p-noise` before 4.1.2 and 5.0.3 does not correctly validate signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Users should upgrade to version 4.1.2 or 5.0.3 to receive a patch. There are currently no known workarounds.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@chainsafe/libp2p-noise4.1.2GHSA-j3ff-xp6c-6gcc
npm@chainsafe/libp2p-noise5.0.3GHSA-j3ff-xp6c-6gcc

Affected products (as reported)

VendorProductVersions
ChainSafe js-libp2p-noise < 4.1.2>= 5.0.0, < 5.0.3

Weakness: CWE-347 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

References