Vulnerability · Published Mar 9, 2022 · Assigned by GitHub_M

CVE-2022-24746HTML injection possibility in voucher code form

Medium 6.1

In plain English

A medium-severity cross-site scripting in platform from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.8%top 41.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions it is possible to inject code via the voucher code form. This issue has been patched in version 6.4.8.1. There are no known workarounds for this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.4.8.1GHSA-952p-fqcp-g8pc
Packagistshopware/platform6.4.8.1GHSA-952p-fqcp-g8pc
Packagistshopware/storefront6.4.8.1GHSA-952p-fqcp-g8pc

Affected products (as reported)

VendorProductVersions
shopware platform < 6.4.8.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References