Vulnerability · Published Mar 9, 2022 · Assigned by GitHub_M

CVE-2022-24744Insufficient Session Expiration in shopware

Low 2.6

In plain English

A low-severity security flaw in platform from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.6Low
Exploit odds (30 days)0.5%top 58.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions user sessions are not logged out if the password is reset via password recovery. This issue has been resolved in version 6.4.8.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistshopware/core6.4.8.1GHSA-w267-m9c4-8555
Packagistshopware/platform6.4.8.1GHSA-w267-m9c4-8555

Affected products (as reported)

VendorProductVersions
shopware platform < 6.4.8.1

Weakness: CWE-613 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N

References