Vulnerability · Published Mar 14, 2022 · Assigned by GitHub_M

CVE-2022-24740Improper Authentication in Volto

Medium 5.0

In plain English

A medium-severity improper authentication in volto from plone. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.0Medium
Exploit odds (30 days)0.6%top 51.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Volto is a ReactJS-based frontend for the Plone Content Management System. Between versions 14.0.0-alpha.5 and 15.0.0-alpha.0, a user could have their authentication cookie replaced with an authentication cookie from another user, effectively giving them control of the other user's account and privileges. This occurs when using an outdated version of the `react-cookie` library and a server is under high load. A proof of concept does not currently exist, but it is possible for this issue to occur in the wild. The patch and fix is present in Volto 15.0.0-alpha.0. As a workaround, one may manually upgrade the `react-cookie` package to 4.1.1 and then override all Volto components that use this library.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@plone/volto15.0.0-alpha.0GHSA-cfhh-xgwq-5r67

Affected products (as reported)

VendorProductVersions
plone volto >= 14.0.0-alpha.5, < 15.0.0-alpha.0

Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L

References