Vulnerability · Published Mar 1, 2022 · Assigned by GitHub_M
CVE-2022-24720Improper Input Validation in image_processing
Critical 9.8
In plain English
A critical-severity improper input validation in image_processing from janko. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 2.7% (higher than 86% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
image_processing is an image processing wrapper for libvips and ImageMagick/GraphicsMagick. Prior to version 1.12.2, using the `#apply` method from image_processing to apply a series of operations that are coming from unsanitized user input allows the attacker to execute shell commands. This method is called internally by Active Storage variants, so Active Storage is vulnerable as well. The vulnerability has been fixed in version 1.12.2 of image_processing. As a workaround, users who process based on user input should always sanitize the user input by allowing only a constrained set of operations.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ruby-image-processing | 1.10.3-2 | DEBIAN-CVE-2022-24720 |
| RubyGems | image_processing | 1.12.2 | GHSA-cxf7-qrc5-9446 |
| Ubuntu:22.04:LTS | ruby-image-processing | 1.10.3-1ubuntu0.22.04.1 | USN-6675-1 |
| Ubuntu:22.04:LTS | ruby-image-processing | 1.10.3-1ubuntu0.22.04.1 | UBUNTU-CVE-2022-24720 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| janko | image_processing | < 1.12.2 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H