Vulnerability · Published Feb 25, 2022 · Assigned by GitHub_M

CVE-2022-24710Cross-site Scripting in Weblate

Medium 5.4

In plain English

A medium-severity cross-site scripting in weblate from WeblateOrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.8%top 44.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Weblate is a copyleft software web-based continuous localization system. Versions prior to 4.11 do not properly neutralize user input used in user name and language fields. Due to this improper neutralization it is possible to perform cross-site scripting via these fields. The issues were fixed in the 4.11 release. Users unable to upgrade are advised to add their own neutralize logic.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIweblate4.11GHSA-6jp6-9rf9-gc66
PyPIweblate4.11PYSEC-2022-35

Affected products (as reported)

VendorProductVersions
WeblateOrg weblate < 4.11

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References