Vulnerability · Published Feb 9, 2022 · Assigned by GitHub_M
CVE-2022-23631Prototype Pollution leading to Remote Code Execution in superjson
Critical 9.1
In plain English
A critical-severity code injection in superjson from blitz-js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.7% (higher than 86% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
superjson is a program to allow JavaScript expressions to be serialized to a superset of JSON. In versions prior to 1.8.1 superjson allows input to run arbitrary code on any server using superjson input without prior authentication or knowledge. The only requirement is that the server implements at least one endpoint which uses superjson during request processing. This has been patched in superjson 1.8.1. Users are advised to update. There are no known workarounds for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | blitz | 0.45.3 | GHSA-5888-ffcr-r425 |
| npm | superjson | 1.8.1 | GHSA-5888-ffcr-r425 |
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/blitz-js/superjson/security/advisories/GHSA-5888-ffcr-r425 x_refsource_CONFIRM
- https://github.com/advisories/GHSA-5888-ffcr-r425 x_refsource_MISC
- https://www.sonarsource.com/blog/blitzjs-prototype-pollution/ x_refsource_MISC