Vulnerability · Published Feb 7, 2022 · Assigned by GitHub_M

CVE-2022-23624Validation bypass in frourio-express

High 8.1

In plain English

A high-severity improper input validation in frourio-express from frouriojs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)1.2%top 30.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Frourio-express is a minimal full stack framework, for TypeScript. Frourio-express users who uses frourio-express version prior to v0.26.0 and integration with class-validator through `validators/` folder are subject to a input validation vulnerability. Validators do not work properly for request bodies and queries in specific situations and some input is not validated at all. Users are advised to update frourio to v0.26.0 or later and to install `class-transformer` and `reflect-metadata`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmfrourio-express0.26.0GHSA-mmj4-777p-fpq9

Affected products (as reported)

VendorProductVersions
frouriojs frourio-express < 0.26.0

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

References