Vulnerability · Published Dec 22, 2022 · Assigned by GitHub_M
CVE-2022-23556CodeIgniter is vulnerable to IP address spoofing when using proxy
High 7.0
In plain English
A high-severity insufficient verification of data authenticity in CodeIgniter4 from codeigniter4. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\App::$proxyIPs`. As a workaround, do not use `$request->getIPAddress()`.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | codeigniter4/framework | 4.2.11 | GHSA-ghw3-5qvm-3mqc |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| codeigniter4 | CodeIgniter4 | < 4.2.11 |
Weakness: CWE-345 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L