Vulnerability · Published Dec 15, 2022 · Assigned by GitHub_M

CVE-2022-23524Helm vulnerable to Denial of service through string value parsing

Medium 5.3

In plain English

A medium-severity uncontrolled resource consumption in helm from helm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.8%top 42.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Helm is a tool for managing Charts, pre-configured Kubernetes resources. Versions prior to 3.10.3 are subject to Uncontrolled Resource Consumption, resulting in Denial of Service. Input to functions in the _strvals_ package can cause a stack overflow. In Go, a stack overflow cannot be recovered from. Applications that use functions from the _strvals_ package in the Helm SDK can have a Denial of Service attack when they use this package and it panics. This issue has been patched in 3.10.3. SDK users can validate strings supplied by users won't create large arrays causing significant memory usage before passing them to the _strvals_ functions.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gohelm.sh/helm/v33.10.3GHSA-6rx9-889q-vv2r
Gohelm.sh/helm/v33.10.3GO-2022-1167

Affected products (as reported)

VendorProductVersions
helm helm < v3.10.3

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References