Vulnerability · Published Dec 14, 2022 · Assigned by GitHub_M

CVE-2022-23518Improper neutralization of data URIs allows XSS in rails-html-sanitizer

Medium 6.1

In plain English

A medium-severity cross-site scripting in rails-html-sanitizer from rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)6.1Medium
Exploit odds (30 days)0.9%top 39.4% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Versions >= 1.0.3, < 1.4.4 are vulnerable to cross-site scripting via data URIs when used in combination with Loofah >= 2.1.0. This issue is patched in version 1.4.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-rails-html-sanitizer1.4.4-1DEBIAN-CVE-2022-23518
Debian:13ruby-rails-html-sanitizer1.4.4-1DEBIAN-CVE-2022-23518
Debian:14ruby-rails-html-sanitizer1.4.4-1DEBIAN-CVE-2022-23518
RubyGemsrails-html-sanitizer1.4.4GHSA-mcvf-2q2m-x72m
Ubuntu:22.04:LTSruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2022-23518
Ubuntu:24.04:LTSruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2022-23518
Ubuntu:25.10ruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2022-23518
Ubuntu:26.04:LTSruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2022-23518
Ubuntu:26.10ruby-rails-html-sanitizerno fix listedUBUNTU-CVE-2022-23518

Affected products (as reported)

VendorProductVersions
rails rails-html-sanitizer >= 1.0.3, < 1.4.4

Weakness: CWE-79 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References