Vulnerability · Published Dec 14, 2022 · Assigned by GitHub_M

CVE-2022-23515Improper neutralization of data URIs may allow XSS in Loofah

Medium 6.1

In plain English

A medium-severity cross-site scripting in loofah from flavorjones. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.9%top 41.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-loofah2.19.1-1DEBIAN-CVE-2022-23515
Debian:13ruby-loofah2.19.1-1DEBIAN-CVE-2022-23515
Debian:14ruby-loofah2.19.1-1DEBIAN-CVE-2022-23515
RubyGemsloofah2.19.1GHSA-228g-948r-83gx
Ubuntu:22.04:LTSruby-loofahno fix listedUBUNTU-CVE-2022-23515

Affected products (as reported)

VendorProductVersions
flavorjones loofah >= 2.1.0, < 2.19.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References