Vulnerability · Published Jan 9, 2023 · Assigned by GitHub_M

CVE-2022-23509Weave Gitops Run vulnerable to insecure communication

High 7.4

In plain English

A high-severity information exposure in weave-gitops from weaveworks. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)0.2%top 83.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise. GitOps run has a local S3 bucket which it uses for synchronizing files that are later applied against a Kubernetes cluster. The communication between GitOps Run and the local S3 bucket is not encrypted. This allows privileged users or process to tap the local traffic to gain information permitting access to the s3 bucket. From that point, it would be possible to alter the bucket content, resulting in changes in the Kubernetes cluster's resources. There are no known workaround(s) for this vulnerability. This vulnerability has been fixed by commits ce2bbff and babd915. Users should upgrade to Weave GitOps version >= v0.12.0 released on 08/12/2022.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/weaveworks/weave-gitops0.12.0GHSA-89qm-wcmw-3mgg
Gogithub.com/weaveworks/weave-gitops0.12.0GO-2023-1388

Affected products (as reported)

VendorProductVersions
weaveworks weave-gitops <= 0.11.0

Weakness: CWE-200 · Vector: CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H

References