Vulnerability · Published Dec 14, 2022 · Assigned by GitHub_M

CVE-2022-23504TYPO3 contains Sensitive Information Disclosure via YAML Placeholder Expressions in Site Configuration

Medium 5.7

In plain English

A medium-severity information exposure in typo3 from TYPO3. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.7Medium
Exploit odds (30 days)0.5%top 53.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

TYPO3 is an open source PHP based web content management system. Versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are subject to Sensitive Information Disclosure. Due to the lack of handling user-submitted YAML placeholder expressions in the site configuration backend module, attackers could expose sensitive internal information, such as system configuration or HTTP request messages of other website visitors. A valid backend user account having administrator privileges is needed to exploit this vulnerability. This issue has been patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagisttypo3/cms10.4.33GHSA-8w3p-qh3x-6gjr
Packagisttypo3/cms11.5.20GHSA-8w3p-qh3x-6gjr
Packagisttypo3/cms12.1.1GHSA-8w3p-qh3x-6gjr
Packagisttypo3/cms-core9.5.38GHSA-8w3p-qh3x-6gjr
Packagisttypo3/cms-core12.1.1GHSA-8w3p-qh3x-6gjr
Packagisttypo3/cms-core10.4.33GHSA-8w3p-qh3x-6gjr
Packagisttypo3/cms-core11.5.20GHSA-8w3p-qh3x-6gjr

Affected products (as reported)

VendorProductVersions
TYPO3 typo3 >= 9.0.0, < 9.5.38>= 10.0.0, < 10.4.33>= 11.0.0, < 11.5.20>= 12.0.0, < 12.1.1

Weakness: CWE-200, CWE-917 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:L/A:L

References