Vulnerability · Published Dec 8, 2022 · Assigned by GitHub_M

CVE-2022-23494Cross-site scripting vulnerability in TinyMCE alerts

Medium 5.4

In plain English

A medium-severity cross-site scripting in tinymce from tinymce. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)1.0%top 36.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

tinymce is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the `image` plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user. This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements. Users are advised to upgrade to either 5.10.7 or 6.3.1. Users unable to upgrade may ensure the the `images_upload_handler` returns a valid value as per the images_upload_handler documentation.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGettinymce6.3.1GHSA-gg8r-xjwq-4w92
NuGettinymce5.10.7GHSA-gg8r-xjwq-4w92
Packagisttinymce/tinymce6.3.1GHSA-gg8r-xjwq-4w92
Packagisttinymce/tinymce5.10.7GHSA-gg8r-xjwq-4w92
npmtinymce6.3.1GHSA-gg8r-xjwq-4w92
npmtinymce5.10.7GHSA-gg8r-xjwq-4w92

Affected products (as reported)

VendorProductVersions
tinymce tinymce < 5.10.7>= 6.0.0, < 6.3.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References