Vulnerability · Published Dec 8, 2022 · Assigned by GitHub_M

CVE-2022-23492go-libp2p denial of service vulnerability from lack of resource management

High 7.5

In plain English

A high-severity uncontrolled resource consumption in go-libp2p from libp2p. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.1%top 35.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

go-libp2p is the offical libp2p implementation in the Go programming language. Version `0.18.0` and older of go-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of go-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. Users are advised to upgrade their version of go-libp2p to version `0.18.1` or newer. Users unable to upgrade may consult the denial of service (dos) mitigation page for more information on how to incorporate mitigation strategies, monitor your application, and respond to attacks.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/libp2p/go-libp2p0.18.0GHSA-j7qp-mfxf-8xjw
Gogithub.com/libp2p/go-libp2p0.18.0GO-2022-1148

Affected products (as reported)

VendorProductVersions
libp2p go-libp2p < 0.18.0

Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References