Vulnerability · Published Dec 6, 2022 · Assigned by GitHub_M
CVE-2022-23466DOM-based cross-site scripting (XSS) in teler dashboard
Medium 5.4
In plain English
A medium-severity cross-site scripting in teler from kitabisa. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
teler is an real-time intrusion detection and threat alert dashboard. teler prior to version 2.0.0-rc.4 is vulnerable to DOM-based cross-site scripting (XSS) in the teler dashboard. When teler requests messages from the event stream on the `/events` endpoint, the log data displayed on the dashboard are not sanitized. This only affects authenticated users and can only be exploited based on detected threats if the log contains a DOM scripting payload. This vulnerability has been fixed on version `v2.0.0-rc.4`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | teler.app | 2.0.0-rc.4 | GHSA-xr7p-8q82-878q |
| Go | teler.app | 2.0.0-dev.2 | GHSA-xr7p-8q82-878q |
| Go | teler.app | 0.0.0-20221203202318-20f59eda2420 | GHSA-xr7p-8q82-878q |
| Go | teler.app | 1.2.3-0.20221203202318-20f59eda2420 | GHSA-xr7p-8q82-878q |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N