Vulnerability · Published Jan 15, 2022 · Assigned by mitre

CVE-2022-23094

High 7.5

In plain English

A high-severity security flaw in the libreswan package (AlmaLinux). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.5% (higher than 85% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)2.5%top 14.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted IKEv1 packet because pluto/ikev1.c wrongly expects that a state object exists. This is fixed in 4.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8libreswan4.4-4.el8_5ALSA-2022:0199
Alpine:v3.20libreswan4.6-r0ALPINE-CVE-2022-23094
Alpine:v3.21libreswan4.6-r0ALPINE-CVE-2022-23094
Alpine:v3.22libreswan4.6-r0ALPINE-CVE-2022-23094
Alpine:v3.23libreswan4.6-r0ALPINE-CVE-2022-23094
Alpine:v3.24libreswan4.6-r0ALPINE-CVE-2022-23094
Debian:12libreswan4.6-1DEBIAN-CVE-2022-23094
Debian:13libreswan4.6-1DEBIAN-CVE-2022-23094
Rocky Linux:8libreswan0:4.4-4.el8_5RLSA-2022:0199
Ubuntu:22.04:LTSlibreswanno fix listedUBUNTU-CVE-2022-23094

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

References