Vulnerability · Published Sep 23, 2022 · Assigned by apple

CVE-2022-22629

High 8.8

In plain English

A high-severity out-of-bounds write in Safari from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 5.0% (higher than 92% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)5.0%top 7.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Monterey 12.3, Safari 15.4, watchOS 8.5, iTunes 12.12.3 for Windows, iOS 15.4 and iPadOS 15.4, tvOS 15.4. Processing maliciously crafted web content may lead to arbitrary code execution.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.36.7-1.el8ALSA-2022:7704
AlmaLinux:9webkit2gtk32.36.7-1.el9ALSA-2022:8054
AlmaLinux:8webkit2gtk3-devel2.36.7-1.el8ALSA-2022:7704
AlmaLinux:9webkit2gtk3-devel2.36.7-1.el9ALSA-2022:8054
AlmaLinux:8webkit2gtk3-jsc2.36.7-1.el8ALSA-2022:7704
AlmaLinux:9webkit2gtk3-jsc2.36.7-1.el9ALSA-2022:8054
AlmaLinux:8webkit2gtk3-jsc-devel2.36.7-1.el8ALSA-2022:7704
AlmaLinux:9webkit2gtk3-jsc-devel2.36.7-1.el9ALSA-2022:8054
Alpine:v3.20webkit2gtk2.36.0-r0ALPINE-CVE-2022-22629
Debian:12webkit2gtk2.36.0-1DEBIAN-CVE-2022-22629
Debian:13webkit2gtk2.36.0-1DEBIAN-CVE-2022-22629
Debian:14webkit2gtk2.36.0-1DEBIAN-CVE-2022-22629
Debian:12wpewebkit2.36.0-2DEBIAN-CVE-2022-22629
Debian:13wpewebkit2.36.0-2DEBIAN-CVE-2022-22629
Debian:14wpewebkit2.36.0-2DEBIAN-CVE-2022-22629
Rocky Linux:8webkit2gtk30:2.36.7-1.el8_6RLSA-2022:7704
Rocky Linux:9webkit2gtk30:2.36.7-1.el9_1.1RLSA-2022:8054
Rocky Linux:9webkit2gtk30:2.36.7-1.el9_0RLSA-2022:8054
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2022-22629
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2022-22629
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2022-22629

Affected products (as reported)

VendorProductVersions
Apple Safari unspecified – before 15.4
Apple tvOS unspecified – before 15.4
Apple tvOS unspecified – before 12.3
Apple tvOS unspecified – before 15.4
Apple watchOS unspecified – before 8.5
Apple watchOS unspecified – before 12.12
Apple watchOS unspecified – before 12.12

Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References