Vulnerability · Published Jan 21, 2022 · Assigned by GitHub_M
CVE-2022-21708Denial of Service in graphql-go
Medium 6.5
In plain English
A medium-severity uncontrolled resource consumption in graphql-go from graph-gophers. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
graphql-go is a GraphQL server with a focus on ease of use. In versions prior to 1.3.0 there exists a DoS vulnerability that is possible due to a bug in the library that would allow an attacker with specifically designed queries to cause stack overflow panics. Any user with access to the GraphQL handler can send these queries and cause stack overflows. This in turn could potentially compromise the ability of the server to serve data to its users. The issue has been patched in version `v1.3.0`. The only known workaround for this issue is to disable the `graphql.MaxDepth` option from your schema which is not recommended.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | golang-github-graph-gophers-graphql-go | 1.3.0-1 | DEBIAN-CVE-2022-21708 |
| Debian:13 | golang-github-graph-gophers-graphql-go | 1.3.0-1 | DEBIAN-CVE-2022-21708 |
| Debian:14 | golang-github-graph-gophers-graphql-go | 1.3.0-1 | DEBIAN-CVE-2022-21708 |
| Go | github.com/graph-gophers/graphql-go | 1.3.0 | GHSA-mh3m-8c74-74xh |
| Go | github.com/graph-gophers/graphql-go | 1.3.0 | GO-2022-0300 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| graph-gophers | graphql-go | < 1.3.0 |
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H