Vulnerability · Published Jan 21, 2022 · Assigned by GitHub_M
CVE-2022-21707Incorrect Authorization in wasmCloud
Medium 6.3
In plain English
A medium-severity incorrect authorization in wasmcloud-otp from wasmCloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities).
Official description
wasmCloud Host Runtime is a server process that securely hosts and provides dispatch for web assembly (WASM) actors and capability providers. In versions prior to 0.52.2 actors can bypass capability authorization. Actors are normally required to declare their capabilities for inbound invocations, but with this vulnerability actor capability claims are not verified upon receiving invocations. This compromises the security model for actors as they can receive unauthorized invocations from linked capability providers. The problem has been patched in versions `0.52.2` and greater. There is no workaround and users are advised to upgrade to an unaffected version as soon as possible.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| wasmCloud | wasmcloud-otp | < 0.52.2 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N