Vulnerability · Published Feb 23, 2022 · Assigned by GitHub_M
CVE-2022-21705Authenticated remote code execution in octobercms
High 7.2
In plain English
A high-severity injection in october from octobercms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 8.6% (higher than 95% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.
Official description
Octobercms is a self-hosted CMS platform based on the Laravel PHP Framework. In affected versions user input was not properly sanitized before rendering. An authenticated user with the permissions to create, modify and delete website pages can exploit this vulnerability to bypass `cms.safe_mode` / `cms.enableSafeMode` in order to execute arbitrary code. This issue only affects admin panels that rely on safe mode and restricted permissions. To exploit this vulnerability, an attacker must first have access to the backend area. The issue has been patched in Build 474 (v1.0.474) and v1.1.10. Users unable to upgrade should apply https://github.com/octobercms/library/commit/c393c5ce9ca2c5acc3ed6c9bb0dab5ffd61965fe to your installation manually.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | october/system | 1.0.474 | GHSA-79jw-2f46-wv22 |
| Packagist | october/system | 1.1.10 | GHSA-79jw-2f46-wv22 |
| Packagist | october/system | 2.1.27 | GHSA-79jw-2f46-wv22 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| octobercms | october | < 1.0.474>= 1.1.0, < 1.1.10>= 2.0.0, < 2.1.27 |
Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H