Vulnerability · Published Jan 25, 2022 · Assigned by GitHub_M

CVE-2022-21697SSRF vulnerability (requires authentication)

Medium 6.3

In plain English

A medium-severity server-side request forgery in jupyter-server-proxy from jupyterhub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)1.1%top 34.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled is affected. A lack of input validation allows authenticated clients to proxy requests to other hosts, bypassing the `allowed_hosts` check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity. Users may upgrade to version 3.2.1 to receive a patch or, as a workaround, install the patch manually.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIjupyter-server-proxy3.2.1GHSA-gcv9-6737-pjqw
PyPIjupyter-server-proxy3.2.1PYSEC-2022-16

Affected products (as reported)

VendorProductVersions
jupyterhub jupyter-server-proxy < 3.2.1

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N

References