Vulnerability · Published Jan 6, 2022 · Assigned by GitHub_M

CVE-2022-21664SQL injection in WordPress

High 7.4

In plain English

A high-severity SQL injection in wordpress-develop from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.7% (higher than 90% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)3.7%top 10.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to lack of proper sanitization in one of the classes, there's potential for unintended SQL queries to be executed. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 4.1.34. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress5.8.3+dfsg1-1DEBIAN-CVE-2022-21664
Debian:13wordpress5.8.3+dfsg1-1DEBIAN-CVE-2022-21664
Debian:14wordpress5.8.3+dfsg1-1DEBIAN-CVE-2022-21664

Affected products (as reported)

VendorProductVersions
WordPress wordpress-develop >= 4.1.33, < 5.8.3

Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

References