Vulnerability · Published Jan 6, 2022 · Assigned by GitHub_M

CVE-2022-21661SQL injection in WordPress

High 8.0

In plain English

A high-severity SQL injection in wordpress-develop from WordPress. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 97.8% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)97.8%top 0.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling2Nuclei, Public PoC

Official description

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress5.8.3+dfsg1-1DEBIAN-CVE-2022-21661
Debian:13wordpress5.8.3+dfsg1-1DEBIAN-CVE-2022-21661
Debian:14wordpress5.8.3+dfsg1-1DEBIAN-CVE-2022-21661

Affected products (as reported)

VendorProductVersions
WordPress wordpress-develop < 5.8.3

Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

References