Vulnerability · Published Aug 26, 2022 · Assigned by redhat

CVE-2022-0216

Medium 4.4

In plain English

A medium-severity use-after-free in QEMU. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)4.4Medium
Exploit odds (30 days)0.4%top 62.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A use-after-free vulnerability was found in the LSI53C895A SCSI Host Bus Adapter emulation of QEMU. The flaw occurs while processing repeated messages to cancel the current SCSI request via the lsi_do_msgout function. This flaw allows a malicious privileged user within the guest to crash the QEMU process on the host, resulting in a denial of service.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12qemu1:7.1+dfsg-1DEBIAN-CVE-2022-0216
Debian:13qemu1:7.1+dfsg-1DEBIAN-CVE-2022-0216
Debian:14qemu1:7.1+dfsg-1DEBIAN-CVE-2022-0216
Ubuntu:22.04:LTSqemu1:6.2+dfsg-2ubuntu6.6USN-5772-1
Ubuntu:22.04:LTSqemu1:6.2+dfsg-2ubuntu6.6UBUNTU-CVE-2022-0216

Affected products (as reported)

VendorProductVersions
n/a QEMU Affects QEMU < v6.0.0, Fixed in v7.1.0-rc0

Weakness: CWE-416

References