Vulnerability · Published Dec 18, 2021 · Assigned by apache

CVE-2021-45105Apache Log4j2 does not always protect from infinite recursion in lookup evaluation

Medium 5.9

In plain English

A medium-severity improper input validation in Apache Log4j2 from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 100.0% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)100.0%top 0.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3 and 2.3.1) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0, 2.12.3, and 2.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12apache-log4j22.17.0-1DEBIAN-CVE-2021-45105
Debian:13apache-log4j22.17.0-1DEBIAN-CVE-2021-45105
Debian:14apache-log4j22.17.0-1DEBIAN-CVE-2021-45105
Mavenorg.apache.logging.log4j:log4j-core2.12.3GHSA-p6xc-xr62-6r2g
Mavenorg.apache.logging.log4j:log4j-core2.17.0GHSA-p6xc-xr62-6r2g
Mavenorg.apache.logging.log4j:log4j-core2.3.1GHSA-p6xc-xr62-6r2g
Mavenorg.ops4j.pax.logging:pax-logging-log4j22.0.13GHSA-p6xc-xr62-6r2g
Mavenorg.ops4j.pax.logging:pax-logging-log4j21.11.12GHSA-p6xc-xr62-6r2g
Mavenorg.ops4j.pax.logging:pax-logging-log4j21.10.9GHSA-p6xc-xr62-6r2g
Mavenorg.ops4j.pax.logging:pax-logging-log4j21.9.2GHSA-p6xc-xr62-6r2g

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Log4j2 log4j-core – before 2.17.0

Weakness: CWE-20, CWE-674 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

References