Vulnerability · Published Dec 9, 2021 · Assigned by GitHub_M
CVE-2021-43797HTTP fails to validate against control chars in header names which may lead to HTTP request smuggling
Medium 6.5
In plain English
A medium-severity security flaw in netty from netty. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.9% (higher than 87% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. Netty prior to version 4.1.71.Final skips control chars when they are present at the beginning / end of the header name. It should instead fail fast as these are not allowed by the spec and could lead to HTTP request smuggling. Failing to do the validation might cause netty to "sanitize" header names before it forward these to another remote system when used as proxy. This remote system can't see the invalid usage anymore, and therefore does not do the validation itself. Users should upgrade to version 4.1.71.Final.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | netty | 1:4.1.48-6 | DEBIAN-CVE-2021-43797 |
| Debian:13 | netty | 1:4.1.48-6 | DEBIAN-CVE-2021-43797 |
| Debian:14 | netty | 1:4.1.48-6 | DEBIAN-CVE-2021-43797 |
| Maven | io.netty:netty | no fix listed | GHSA-wx5j-54mm-rqqq |
| Maven | io.netty:netty-codec-http | 4.1.71.Final | GHSA-wx5j-54mm-rqqq |
| Maven | org.jboss.netty:netty | no fix listed | GHSA-wx5j-54mm-rqqq |
| Rocky Linux:8 | libdb | 0:5.3.28-42.el8_4 | RLSA-2022:5498 |
| Ubuntu:22.04:LTS | netty | 1:4.1.48-4+deb11u1build0.22.04.1 | USN-6049-1 |
| Ubuntu:22.04:LTS | netty | 1:4.1.48-4+deb11u1build0.22.04.1 | UBUNTU-CVE-2021-43797 |
Affected products (as reported)
Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
References
- https://github.com/netty/netty/security/advisories/GHSA-wx5j-54mm-rqqq
- https://github.com/netty/netty/commit/07aa6b5938a8b6ed7a6586e066400e2643897323
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://security.netapp.com/advisory/ntap-20220107-0003/
- https://www.oracle.com/security-alerts/cpujul2022.html
- [debian-lts-announce] 20230111 [SECURITY] [DLA 3268-1] netty security update mailing-list
- DSA-5316 vendor-advisory