Vulnerability · Published Nov 24, 2021 · Assigned by GitHub_M
CVE-2021-43778Path traversal in GLPI barcode plugin
Critical 9.1
In plain English
A critical-severity path traversal in barcode from pluginsGLPI. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 52.7% (higher than 99% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code.
Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)52.7%top 1.0% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling2Nuclei, Public PoC
Official description
Barcode is a GLPI plugin for printing barcodes and QR codes. GLPI instances version 2.x prior to version 2.6.1 with the barcode plugin installed are vulnerable to a path traversal vulnerability. This issue was patched in version 2.6.1. As a workaround, delete the `front/send.php` file.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| pluginsGLPI | barcode | >= 2.0.0, < 2.6.1 |
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
References
- https://github.com/pluginsGLPI/barcode/security/advisories/GHSA-2pjh-h828-wcw9 x_refsource_CONFIRM
- https://github.com/pluginsGLPI/barcode/commit/428c3d9adfb446e8492b1c2b7affb3d34072ff46 x_refsource_MISC
- https://github.com/hansmach1ne/MyExploits/tree/main/Path%20Traversal%20in%20GLPI%20Barcode%20plugin x_refsource_MISC
- https://github.com/pluginsGLPI/barcode/releases/tag/2.6.1 x_refsource_MISC
- https://github.com/hansmach1ne/CVE-portfolio/tree/main/CVE-2021-43778