Vulnerability · Published Nov 26, 2021 · Assigned by GitHub_M

CVE-2021-43776XSS vulnerability in @backstage/plugin-auth-backend

High 7.4

In plain English

A high-severity cross-site scripting in backstage from backstage. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)0.7%top 47.5% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Backstage is an open platform for building developer portals. In affected versions the auth-backend plugin allows a malicious actor to trick another user into visiting a vulnerable URL that executes an XSS attack. This attack can potentially allow the attacker to exfiltrate access tokens or other secrets from the user's browser. The default CSP does prevent this attack, but it is expected that some deployments have these policies disabled due to incompatibilities. This is vulnerability is patched in version `0.4.9` of `@backstage/plugin-auth-backend`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@backstage/plugin-auth-backend0.4.9GHSA-w7fj-336r-vw49

Affected products (as reported)

VendorProductVersions
backstage backstage < 0.4.9

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

References