Vulnerability · Published Jun 7, 2023 · Assigned by Wordfence

CVE-2021-4374WordPress Automatic Plugin <= 3.53.2 - Unauthenticated Arbitrary Options Update

Critical 9.1

In plain English

A critical-severity missing authorization in WordPress Automatic Plugin from ValvePress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 16.4% (higher than 97% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)16.4%top 3.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling2Metasploit, Nuclei

Official description

The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the process_form.php file. This makes it possible for unauthenticated attackers to arbitrarily update the settings of a vulnerable site and ultimately compromise the entire site.

Affected products (as reported)

VendorProductVersions
ValvePress WordPress Automatic Plugin 0 – before 3.53.3

Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

References