Vulnerability · Published Dec 3, 2021 · Assigned by mitre
CVE-2021-43415
High 8.8
In plain English
A high-severity security flaw in the github.com/hashicorp/nomad package (Go). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)8.8High
Exploit odds (30 days)1.2%top 31.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task driver enabled, allowed authenticated users with job submission capabilities to bypass the configured allowed image paths. Fixed in 1.0.14, 1.1.8, and 1.2.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/nomad | 1.0.14 | GHSA-2jhh-5xm2-j4gf |
| Go | github.com/hashicorp/nomad | 1.1.8 | GHSA-2jhh-5xm2-j4gf |
| Go | github.com/hashicorp/nomad | 1.2.1 | GHSA-2jhh-5xm2-j4gf |
| Go | github.com/hashicorp/nomad | 1.0.14, 1.1.8, 1.2.1 | GO-2022-0573 |