Vulnerability · Published Jan 7, 2023 · Assigned by VulDB

CVE-2021-4306cronvel terminal-kit redos

Low 3.5

In plain English

A low-severity regular-expression denial of service in terminal-kit from cronvel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.5Low
Exploit odds (30 days)1.0%top 37.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmterminal-kit2.1.8GHSA-wxgh-8gmr-3qh3

Affected products (as reported)

VendorProductVersions
cronvel terminal-kit 2.1.02.1.12.1.22.1.32.1.42.1.52.1.62.1.7

Weakness: CWE-1333 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

References